Install PHP4 as mod_php, and PHP5 as FastCGI only?

Benjamin Kudria ben at kudria.net
Fri Jun 29 19:56:39 BST 2007


Hi,

Is it possible to install PHP4 as an Apache module, and PHP5 as a FastCGI 
library?  I've installed PHP4 with only Apache module support, but Ports 
won't let me install PHP5 (with only FastCGI support enabled) with the 
message:

---
Build complete.
Don't forget to run 'make test'.

===>  Installing for php5-5.2.3

===>  php5-5.2.3 conflicts with installed package(s):
      php4-4.4.7

      They install files into the same place.
      Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/lang/php5.

---

Is it possible to do this with Ports?  If so, how?  I'm running FreeBSD 
6.1-RELEASE-p10.


Thanks!
Benjamin Kudria




More information about the Ukfreebsd mailing list