Portupgrade won't upgrade

Edmund Craske edmund at m00is.net
Thu Jun 22 15:22:36 BST 2006

Sorry to butt in, and I have trouble with editing messages inline...
I'll just say that I don't believe this is anything to do with the way
portupgrade works, but to do with the way that the ports system works.
When it's installing portupgrade, it checks for a file that
ldconfig_compat should have installed, and as it doesn't find it, it
assumes that ldconfig_compat isn't installed, and tries to install it.
When it does this, it finds that it's already installed, and dies. So
you need to work out why the file that it's looking for isn't there,
and/or persuade portupgrade to install anyway (eg edit the makefile and
remove its check for ldconfig_compat).


Spadge wrote:
> Michael Abbott wrote:
>>> Try pkg_delete?
>> I'm not sure: I think the ldconfig_compat port is rather basic; I'll
>> have to open the box and look inside it, I guess.  I'm hoping that
>> somebody else gets there before me though, 'cause I don't know the
>> innards of ports at all well.  I've already tried `make deinstall`,
>> anyhow.
>>> When I ran portupgrade on itself just now, it went ahead with no
>>> problems at all.
>> I'm going to guess that you don't actually have ldconfig_compat
>> installed: I'm still on 4.11!
> spadge at tobermory$ where ldconfig
> ldconfig_compat-1.0_7 is in misc/ldconfig_compat
> spadge at tobermory$ uname -a
> FreeBSD tobermory.home 6.1-RELEASE FreeBSD 6.1-RELEASE #8: Tue May  9
> 21:04:02 BST 2006     root at tobermory.home:/usr/obj/usr/src/sys/TOBERMORY
>  i386
> Yup, that's installed. It does keep telling me it's marked as ignore
> though, as it's in the base rc.d
>>> And by the way ... Hi there Spidey, long time no see. You should by
>>> waffles again some time, it's been like forever since we saw you
>>> there. :D
>> Yes, I fear it has been forever!  The box I was running my ircd on
>> upped and died some time late last year (an old 1G SCSI disk decided
>> that it was tired, I guess), and, well, um, ... it's time I dropped
>> by!  I'll come by soon.
> It'd be great to see you there again.
> Oh, we have a shiny new ircd we use now. It's a lot more modern than
> that smelly old bahamut one we ran for 4 years :D
>>> Is there some ruby thing that needs updating as well?
>> Don't think so, the ruby update went smoothly.  I actually ran
>>     # portupgrade -R portupgrade
>> and all the other stuff went through just fine.  Indeed, I'm pretty
>> sure that ldconfig_compat just crept in through a `portupgrade -R`
>> somewhere.
>>> do a 'portupgrade -Fa' and see what needs doing. If ruby is on the
>>> list then you're going to want to do that first.
>> $ portupgrade -n portupgrade
>> --->  Session started at: Thu, 22 Jun 2006 13:59:57 +0000
>> --->  Upgrade of sysutils/portupgrade started at: Thu, 22 Jun 2006
>> 13:59:58 +0000
>> --->  Upgrading 'portupgrade-2.0.1_1,1' to 'portupgrade-2.1.1,2'
>> (sysutils/portupgrade)
>> OK? [no]
>> --->  Upgrade of sysutils/portupgrade ended at: Thu, 22 Jun 2006
>> 13:59:58 +0000 (consumed 00:00:00)
>> --->  Listing the results (+:done / -:ignored / *:skipped / !:failed)
>>         + sysutils/portupgrade (portupgrade-2.0.1_1,1)
>> --->  Packages processed: 1 done, 0 ignored, 0 skipped and 0 failed
>> --->  Session ended at: Thu, 22 Jun 2006 13:59:58 +0000 (consumed
>> 00:00:01)
>> Sigh.  When ports have fits, they're painful!
> Indeed.
> pkgdb -Fu maybe? Does portupgrade perhaps not realise that
> ldconfig_compat has been upgraded?

More information about the Ukfreebsd mailing list