Portupgrade won't upgrade

Michael Abbott michael at araneidae.co.uk
Thu Jun 22 14:07:53 BST 2006


Slightly iffy command, perhaps, but it's worked just fine in the past:
 	# portupgrade portupgrade

Now fails miserably, and can't see what the root error is: the build 
seemed to go just fine, but when it tries to upgrade it chokes.  I've 
tried deinstalling and reinstalling the ldconfig_compat port, as 
suggested, but that makes no difference.

Any suggestions?  (I always feel trepidation when about to run 
portupgrade.)

Ah: lest I forget, here's my uname:

$ uname -a
FreeBSD saturn.araneidae.co.uk 4.11-RELEASE-p11 FreeBSD 4.11-RELEASE-p11 
#6: Sat Aug 27 16:33:58 GMT 2005 
root at saturn.araneidae.co.uk:/usr/obj/usr/src/sys/GENERIC  i386

The rest is the portupgrade message:


--->  Backing up the old version
--->  Uninstalling the old version
--->  Deinstalling 'portupgrade-2.0.1_1,1'
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 163 packages 
found (-1 +0) (...) done]
--->  Installing the new version via the port
===>  Installing for portupgrade-2.1.1,2
===>   portupgrade-2.1.1,2 depends on file: /usr/local/bin/ruby18 - found
===>   portupgrade-2.1.1,2 depends on file: 
/usr/local/lib/ruby/site_ruby/1.8/i386-freebsd4/bdb.so - found
===>   portupgrade-2.1.1,2 depends on file: /usr/local/libdata/ldconfig - 
not found
===>    Verifying reinstall for /usr/local/libdata/ldconfig in 
/usr/ports/misc/ldconfig_compat
===>  Extracting for ldconfig_compat-1.0_7
===>  Patching for ldconfig_compat-1.0_7
===>  Configuring for ldconfig_compat-1.0_7
===>  Installing for ldconfig_compat-1.0_7
===>   ldconfig_compat-1.0_7 depends on file: /usr/local/etc/rc.subr - 
found
===>   Generating temporary packing list
===>  Checking if misc/ldconfig_compat already installed
===>   ldconfig_compat-1.0_7 is already installed
       You may wish to ``make deinstall'' and install this port again
       by ``make reinstall'' to upgrade it properly.
       If you really wish to overwrite the old port of misc/ldconfig_compat
       without deleting it first, set the variable "FORCE_PKG_REGISTER"
       in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/misc/ldconfig_compat.
*** Error code 1

Stop in /usr/ports/misc/ldconfig_compat.
*** Error code 1

Stop in /usr/ports/sysutils/portupgrade.
*** Error code 1

Stop in /usr/ports/sysutils/portupgrade.
** Command failed [exit code 1]: /usr/bin/script -qa 
/tmp/portupgrade17723.0 make reinstall
egrep: /var/db/pkg/portupgrade-2.0.1_1,1/+CONTENTS: No such file or 
directory
--->  Restoring the old version
** Fix the installation problem and try again.
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 164 packages 
found (-0 +1) . done]
** Listing the failed packages (*:skipped / !:failed)
         ! sysutils/portupgrade (portupgrade-2.0.1_1,1)  (install error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed





More information about the Ukfreebsd mailing list