possible problem after portupgrade

david morgan morgad at eclipse.co.uk
Sun Aug 13 16:32:55 BST 2006


Hi,
I ran a 'portupgrade vlc' which also installed/upgraded some other stuff,=
 and am confused by the
resulting list of installed ports/packages.

(rearranged 'diff -u version_report.txt version_report-new.txt' follows)

--- version_report.txt  Sat Aug 12 18:44:20 2006
+++ version_report-new.txt      Sat Aug 12 21:10:29 2006

updated as expected:
-vlc-0.8.4a_2                        <   needs updating (port has =
0.8.5_4)
+vlc-0.8.5_4                         =3D   up-to-date with port

new installs:
+avahi-0.6.12                        =3D   up-to-date with port
+gpac-libgpac-0.4.2.r2,1             =3D   up-to-date with port
+libopendaap-0.4.0_1                 =3D   up-to-date with port
+sdl_image-1.2.4_1                   =3D   up-to-date with port
+speex-1.0.5_1,1                     =3D   up-to-date with port
+x264-0.0.20060808                   =3D   up-to-date with port

other upgrades:
 gnutls-1.2.10_1                     <   needs updating (port has 1.4.2)
+gnutls-1.4.2                        =3D   up-to-date with port

 libcdio-0.76_1                      <   needs updating (port has 0.77)
+libcdio-0.77                        =3D   up-to-date with port

 libgpg-error-1.1                    <   needs updating (port has 1.3)
+libgpg-error-1.3                    =3D   up-to-date with port

 libgsf-1.13.3_1                     <   needs updating (port has 1.14.1)
+libgsf-1.14.1                       =3D   up-to-date with port

for these four ports, the versions previously installed (by sysinstall, =
from packages) have
apparently not been removed.

what did I do wrong (or is this duplcattion ok?), and how do I repair =
things?

best regards
Dave
--=20
http://www.morgad.no-ip.info/index.html    gpg:0x64B5E037=20
Distributed Proofreaders: http://www.pgdp.net
The NTP server pool http://www.pool.ntp.org
http://stellar-attraction.com/




More information about the Ukfreebsd mailing list