Sound on Asus A8V-MX (ALC653)

Christopher Dawkins cchd at
Wed Apr 12 19:22:50 BST 2006

>> I'm having big trouble getting sound to work on an Asus A8V-MX motherboard
>> with 6.1-PRERELEASE and KDE 3.5.1. The motherboard has the K8M800/VT8351
>> chipset with ALC653 on-board. The snd_via8233 driver locks onto this and
>> appears to work, generating audio, dsp and dspW devices in /dev and
>> reporting on sndstat "pcm0: <VIA VT8233X> at io 0xd400 irq 22 kld
>> snd_via8233 (5p/1r/0v channels duplex default)"
>> These work:          KDE sound, Noatun, KsCD, xine
>> These do not work:   Audacity, qemu, g711conv, skype, vlc, mplayer
>> I think those that work are working through artsd.

> Have you tried killing artsd and then trying your programs that do not
> work? Artsd is a complete hog, and has been known to completely
> monopolise the sound card (at least on Linux systems).
> Give it a go, and post what happens.

Many thanks for the comment. Just tried it. No joy. No sound, as before.

I've realised that I did in effect try that last week, as I have on a
clean reboot tried output with g711conv, before starting KDE.

Interestingly, after killing artsd, noatun refused to start. Running
xine after killing artsd gives the message

   audio_oss_out: DSP_GETODELAY ioctl():: Invalid argument

which I suspect is quite reasonable. It worked fine after restarting artsd
using the KDE control panel.

But the original errors messages remain. I take the liberty of repeating
them here for convenience in case anyone can say "that's obvious, you need
to reinstall xxx":

(e.g. from audacity)
                portaudio: write interrupted

(e.g. from vlc and others)
           OSS audio output error: write failed (invalid argument)

Christopher Dawkins
  Garnetts Corner, Braintree Road, Felsted, Dunmow, Essex  CM6 3DS
  cchd at     07816 821659     01371 821076

More information about the Ukfreebsd mailing list