I will give my soul to whoever can make my printer work properly...

Ben Paley ben at spooty.net
Wed Jan 5 11:45:48 GMT 2005


...because when my wife discovers she's switched to bsd and now she can't 
print anything I might as well be in hell anyway. She hasn't really noticed 
yet because of Christmas, but she starts work again tomorrow...

It's an Epson R300. It prints absolutely fine from gimp - in printer setup I 
just chose the correct printer and command is lpr - no bother...

But nothing else works properly, not even

lptest 20 5 > /dev/ulpt0

WHICH WORKED YESTERDAY!!! I have a big stack of wasted paper to prove it. 
Neither does

lptest 20 5 | lpr

(that worked yesterday as well - I have no idea what changed) although they 
both do a reset hiccup. I'm using cups, and I've made several ppd files with 
foomatic, to no avail. All my ports are up-to-date as of a couiple of days 
ago.


su-2.05b# cat /etc/printcap
# This file was automatically generated by cupsd(8) from the
# /usr/local/etc/cups/printers.conf file.  All changes to this file
# will be lost.
Epson|Epson Stylus Photo R300:rm=potato.hogsedge.net:rp=Epson:


su-2.05b# cat /usr/local/etc/cups/printers.conf
# Printer configuration file for CUPS v1.1.22
# Written by cupsd on Wed Jan  5 11:24:13 2005
<DefaultPrinter Epson>
Info Epson Stylus Photo R300
Location /dev/ulpt0
DeviceURI usb:/dev/ulpt0
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>



Can't think of anything else - more info on application.

Thank you very much for your help,
Ben




More information about the Ukfreebsd mailing list