SiS83C601 hard disk controller not found

Chris Whitehouse chris at childeric.freeserve.co.uk
Tue Sep 14 21:32:51 BST 2004


Hi all

I am trying to install freebsd on an old laptop but sysinstall can't see the hard disk. The machine is a Pico 6200AT - I'm pretty sure it's a rebadged Clevo 6200AT.  It doesn't boot from CD so I'm booting from floppies 
using kern.flp and mfsroot.flp. When I try to set up a partition I get "No disks found! Please verify that your disk controller is being properly probed at boot time. ..."

The IDE controller is SiS83C601. Output from Sandra system analyser software is

<< Silicon Integrated Systems (SiS) SiS83C601 PCI Enhanced IDE Controller >>
  < Device Information >
    Device Type:                   ATA Disk Controller
    Device ID:                     bus 0, device 1, function 1
    Windows Device Name:           Standard Dual PCI IDE Controller
    OEM Device Name:               Silicon Integrated Systems (SiS) SiS83C601 
                                   PCI Enhanced IDE Controller
    OEM Hardware ID:               FUN_1, VEN_1039, DEV_0601, REV_01
    Revision:                      A / 2 (1)

 Sandra also notes:

  < Performance Tips >
    Tip 1202:                      Device does not support bus mastering.


I found a very similar issue in http://www.freebsd.org/cgi/query-pr.cgi?pr=20035 which says it has been fixed since 4.2.

I tried with 4.10 and 4.9, also 5.2.1 which gave a different message but looked like the same failure (I can give the details if relevant)

I also tried 4.4 and got

ata0-master: ata_command: timeout waiting for intr
ata0_master: identify failed
ata1-master: ata_command: timeout waiting for intr
ata1_master: identify failed

Can I install or should I give up? I wondered if it is that the relevant driver is just not on the boot floppies.

Thanks for any help

Chris







More information about the Ukfreebsd mailing list