John Seago johnseago at two-ravens.org.uk
Fri Nov 19 19:47:43 GMT 2004

On Friday 19 Nov 2004 15:17, Matthew Seaman=20
<m.seaman at infracaninophile.co.uk> wrote:
> On the specific point of configuring X, what you should do is:
> =A0 =A0 =A0# Xorg -configure
> This will probe your hardware and write out a basic configuration file
> into /root/. =A0Then:
> =A0 =A0 =A0# mkdir /etc/X11
> =A0 =A0 =A0# mv /root/xorg.conf.new /etc/X11/xorg.conf
> Now, you should be able to run 'startx' and get a default grey desktop
> with a mouse cursor. =A0Use 'Ctrl-Alt-Backspace' to quit out of X.

=46ollowing your instructions to the letter resulted in a small panel in th=
middle of my monitor telling me "Signal out of range". However using=20
vi /etc/X11/xorg.conf got me into the Xorg config file which in no way=20
resembles the Linux version! I blundered in and altered the bits I thought=
might be the right ones and got back to the Login, Xterm and small clock=20
I've seen before when I did get an install which gave me working 'X' so=20
I've got 'X' working at last.

> To do all of the fine adjustments to the X setup, like telling it to use=
> a UK keyboard, etc. you can either edit the xorg.conf file directly, or=20
> you can use xorgcfg(1) to tweak the automatically generated config file.=
>  The sort of things you might want to change are the default screen=20
> resolution and colour depth, keyboard mapping, font paths etc.=20

The problem here is that I need to understand the conf file, I'll read up=20
on it.

I tried the < pkg_add -r mc > command, but it couldn't find an ftp address,=
again I'll read up and try and solve that one myself.

I am now seriously considering that FreeBSD as an alternative Operating=20
System, (particularly in view of the previous speed of 4.10, as set up by=20
me on my equipment), may not fit with my needs, skills and level of=20
experience, I will give the matter some thought over the weekend,=20
particularly as even the command line seems to be very slow. Thank you =20
once again everyone who has tried to guide my blundering steps. the space=20
is available I may just leave it there and see if i can read enough to get=
it working.
John Seago
Linux User #219566 (http://counter.li.org)

More information about the Ukfreebsd mailing list