TERM and SSH

David Jenkins jaco2001uk at ntlworld.com
Thu Jun 10 21:26:57 BST 2004


Hi all,

I have been a member of this mailing list for quite some time but have 
never posted or responded to a question so please take it easy with me :-).

I have been using FreeBSD for about a year I suppose but have not until 
recently (I don't know why this is) come across this problem.

I've googled it, but can't seem to find any answers (I'm probably 
searching for the wrong thing).

Fresh install of FreeBSD 5.2.1

When I SSH from the FreeBSD machine to my Linux box (It's a 
Sparcstation, otherwise it would have  FreeBSD too ;)) and then say try 
editing a file with vi I get this error:

vi: cons25: unknown terminal type.

... and vi won't start. At the remote prompt I then (using BASH) 

export TERM=vt100 or xterm (I've tried both)

This allows me to open the file with vi but I cannot use the cursor keys 
(they print multiple characters to the screen).

I have tried chaging cons25 in /etc/ttys to xterm or vt100 prior to 
SSHing but I still get the same problem.

Interestingly (and perhaps relevant !?), the problem does not exist when 
using the Windows SSH client PuTTY.

Has anyone got any ideas what I need to do or what I need to search for 
in Google?

Any help would be appreciated.

(Apologies if this is a stupid question but I haven't had much luck 
finding a solution)

Regards,
David




More information about the Ukfreebsd mailing list