missing /dev/tty0

Frank Shute frank at esperance-linux.co.uk
Wed Feb 25 02:18:42 GMT 2004


On Tue, Feb 24, 2004 at 03:32:05PM +0000, Ben Paley wrote:
>
> On Monday 23 February 2004 11:37 pm, you wrote:
> 
> > This looks like a Linuxism. I notice the port depends on linux_base.
> 
> Perhaps it wants /usr/compat/linux/dev/tty0 ?sadly, there is noe /usr/compat/
> linux/dev on my system. That might explain it!

None on mine, even though I've got linux_base. I guess the emulation
layer (or whatever it's called) is meant to pick up anything to
/dev/tty0 and redirect it to /dev/ttyv0. Are you sure you've got the
linux module loaded up? kldstat will give you the answer.

> 
> > I guess you built vmware from ports, so one way of fixing things would
> > be to deinstall/reinstall it (the size of it along with the speed of
> > your machine will determine how painful that is :) 
> 
> I can always go to sleep. Worse is my fear that it just wouldn't compile. On 
> the other hand, it doesn't work now, so I'm hardly losing out, am I?

True. Maybe if the linux module isn't loaded you don't have to rebuild
it.

> 
> Or a bodge might
> > be:
> >
> > # ln -s /dev/ttyv0 /dev/tty0
> 
> This is the kind of thing my friends tell me off for doing :)

You've got good friends. It's the sort of bodge I resort to because
I don't have any good friends to control my more reckless instincts ;)

> 
> >
> > Disclaimer: I know nothing about vmware & am largely shooting in the
> > dark.
> 
> More than me, anyway. Thanks a lot for your help, I really appreciate it.
> 

No worries. Sorry I couldn't specifically diagnose your problem.

Regards,

-- 

 Frank 

*-*-*-*-*-*-*-*-*-*-*
   Boroughbridge.
 Tel: 01423 323019
     ---------
PGP keyID: 0xC0B341A3
*-*-*-*-*-*-*-*-*-*-*

http://www.esperance-linux.co.uk/

PS. Hope you don't mind me posting this to the list also; somebody on
there might be able to add something useful or correct me if I'm
wrong.





More information about the Ukfreebsd mailing list