ls mystery

Frank Shute frank at
Mon Feb 16 21:32:22 GMT 2004

On Mon, Feb 16, 2004 at 08:34:11PM +0000, Pete French wrote:
> > I think it's an alias/variable in my environment that's screwing it
> > up, namely:
> >
> > alias ls='ls -G'
> ....
> > Maybe you could see if you can replicate that behaviour on 4.9
> > RELEASE. If so, I'll file a pr, assuming one hasn't been filed
> > already.
> I just tried to replicate the bahvious on -RELEASE and it doesnt do it
> for me I am afraid. I have tried using bash and also /bin/sh and /bin/csh
> On all of them I get the expected behaviour that 'ls somedir' shows 'somefile'
> properly. The lack of 'x' bits on the directory prevents me from changing
> into it, but I can still see the files.

Thanks for trying that. I've also rebuilt this machine:

$ uname -r


But it's still doing it :(

There's some sort of weirdness going on between the shell, it's
environment and ls....I'll have to do some more work to chase it down.
Have to get this machine functional again...had my usual run-in with
the hateful gettext.



 Tel: 01423 323019
PGP keyID: 0xC0B341A3

More information about the Ukfreebsd mailing list