802.11g and 5.X

geffy at geffychan.co.uk geffy at geffychan.co.uk
Thu Feb 12 12:43:53 GMT 2004


I have FreeBSD 5.2 and have a DLink DWL-G650 11g wireless card which uses the 
Atheros 5212 chipset as well as far as I can remember, it is supported by the 
ATH driver set. The card works to some extent in that it sets itself with a 
ipv6 address and seems to pick up the Wireless SSID properly as I have that set 
to broadcast on the router, and it also gets the Channel right, but I cant seem 
to get the card to use an IPv4 address which would actually allow it to be used 
on the wireless network. I have tried assigning an IPv4 address to it at boot 
in the rc.conf file but that still doesnt seem to work quite properly.
So far I have only had limited success with the ATH card.
To be completely fair though this is the first time I have ever messed with 
wireless so it could be down to my own ineptness.

Geoffrey Garside

Quoting Paul Robinson <paul at iconoplex.co.uk>:

> Hi all,
> 
> Anybody got any good reports of using 802.11g laptop PC cards with 5.X? I 
> hear that the Dlink DWL-AG650 is supposed to work, as is anything else on an
> 
> Atheros 5212 chipset, but I want to be sure before shelling out some 70 
> notes on one. And yes, it does need to be g, and not a or b (although being 
> able to support those as a fallback is a bonus).
> 
> Suggestions? Googling and the handbook are not being too great in this 
> respect. Saying "a card with this chipset should work" is not the same as 
> saying "if you buy THIS card from dabs, it will work, and works for me".
> 
> Pint of beer in this for somebody...
> 
> -- 
> Paul Robinson
> 
> ------ FreeBSD UK Users' Group  -  Mailing List ------
> http://listserver.uk.freebsd.org/mailman/listinfo/freebsd-users
> 







More information about the Ukfreebsd mailing list