courier-imap upgrade broke my webmail

Scott Mitchell scott+freebsd at fishballoon.org
Thu Apr 22 09:51:21 BST 2004


On Wed, Apr 14, 2004 at 09:09:57PM +0100, Jonathan Belson wrote:
> Hiya
> 
> 
> I had a working webmail system using courier-imap and squirrel mail...I just
> did
> a quick upgrade to courier-imap-3.0.3,1 and now it's broken :-(  Whenever I
> try
> to log in, I get the message "ERROR : Connection dropped by imap-server"
> 
> I have the latest squirrelmail (1.4.2_1) and upgraded to courier-imap
> 3.0.3,1.
> 
> I'm not going to have the time to debug this until the weekend, did anyone
> else
> get bitten by the same problem and want to share some clues? :-)
> 
> Cheers,

Hi Jonathan,

Did you get this sorted out?  I just did the upgrade from courier-imap
2.whatever to 3.0.3 last night, and had exactly the same problem until I
replaced my existing /usr/local/etc/courier-imap/{imapd,imapd-ssl} with the
new /usr/local/etc/courier-imap/{imapd,imapd-ssl}.dist installed by the
port.  I believe it's the new MAILDIRPATH directive at the end of these
files that makes all the difference - see the commit message when the 3.0
update went in:
http://www.freebsd.org/cgi/cvsweb.cgi/ports/mail/courier-imap/Makefile?rev=1.70&content-type=text/x-cvsweb-markup

I think the various startup files in /usr/local/etc/rc.d changed as well,
but that didn't seem to prevent anything from starting.

HTH,

	Scott

-- 
===========================================================================
Scott Mitchell           | PGP Key ID | "Eagles may soar, but weasels
Cambridge, England       | 0x54B171B9 |  don't get sucked into jet engines"
scott at fishballoon.org | 0xAA775B8B |      -- Anon




More information about the Ukfreebsd mailing list