Spamassasin error

Dominic Mitchell dom at
Mon Oct 20 09:30:47 BST 2003

On Mon, Oct 20, 2003 at 09:05:50AM +0100, David Richards wrote:
> hi
>    last nite i tried to install spamassasin. The install went fine. But when i tried to start it, I got the following error
> -- core-2# sh /usr/local/etc/rc.d/ start
> File::Spec version 0.8 required--this is only version 0.6 at /usr/local/lib/perl5/site_perl/5.005/Mail/ line 68.
> BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.005/Mail/ line 68.
> BEGIN failed--compilation aborted at /usr/local/bin/spamd line 30.
> I am running 4.9-rc  and SpamAssassin-2.60
> any ideas how I can fix this ?

You can try installing the devel/p5-File-Spec port.  But it's probably
easier to remove perl from the base system and use the lang/perl5.8 port
instead.  That comes with a newer File::Spec builtin, and has a lot
fewer bugs...

When you install perl from the port, you get a "use.perl" script which
lets you switch between the system perl and the port perl.


More information about the Ukfreebsd mailing list