Can't find Intel EtherExpress isa NIC

Chris Whitehouse chris at
Sat May 17 00:39:54 BST 2003


I can't get my system to recognise an Intel EtherExpress 16 card. I have tried various irq and port settings in the kernel 
(make clean and recompile each time). I am setting the card itself with the Intel softset.exe utility. I have set the memory on 
the card to 32Mb starting at d0000 as per INSTALL.TXT and I'm not using the mcd driver also mentioned in 
INSTALL.TXT. I have tried removing all other cards from the computer except the agp graphics card. I have tried 
reserving and releasing irq and iomem in the bios. I've also set the card to the default settings in GENERIC and booted 

I haven't exhaustively tried all combinations of all the different factors but in all these attempts I have not seen any 
reference to ie0 in dmesg. If I misconfigure a 3c509 I see ep0 driver errors in dmesg.

The card works fine in WinNT4 using an alternate disk on the same computer and the ISA slot works with a 3c509 so I 
don't think it's physical hardware.

device		ie0	at isa? port 0x300 irq 10 iomem 0xd0000

Any suggestion much appreciated.

Is there a way to probe the card directly?



More information about the Ukfreebsd mailing list