Problems building 4.8 Kernel

Pete French pete at twisted.org.uk
Tue Jul 1 20:52:17 BST 2003


> I'm running 4.7-RELEASE-p4 and want to move onto 4.8. I got to
> 4.7 via cvsup and building a kernel on 4.6.

Have you tried building the 4.8 kernel on the 4.7 system ? It
shouldnt make a difference, but might...

> After numerous errors about unsupported options: NFS, MFS, UCONSOLE -
> which I bypass by commetning out, when I then run config, I get...
> # /usr/sbin/config JACOB
...
> Your version of config(8) is out of sync with your kernel source.

Thats probably because you are using '/usr/sbin/config' - you should be using
the version of config which was built when you did a 'make buildworld' which
is needed before trying to compile the kernel.

The best way is to do it from /usr/src rather than running config by hand.

# rm -r /usr/obj
# cd /usr/src
# make buildworld
# make KERNCONF=JACOB buildkernel

should do the trick...

-bat.

PS: if you are commign from 4.6 you might need to do a 'mergemaster -p'
before the world will compile!




More information about the Ukfreebsd mailing list