floppy drive

Frank Shute frank at esperance-linux.co.uk
Sun Jan 19 13:05:44 GMT 2003


I'm wondering if my floppy drive has had it. I've noticed that most of
the floppies I've used with mtools are now unreadable :(

# mdir a:

plain_io: Input/output error
Error reading fat number 0
plain_io: Input/output error
Error reading fat number 1
Could not read first FAT sector
Cannot initialize 'A:'

# dmesg -a | grep fd


fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
fd0c: hard error reading fsbn 19 of 1-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 10-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 1-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 10-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 1-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 10-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 0 (No status)
fd0c: hard error reading fsbn 0 (No status)
fd0c: hard error reading fsbn 19 of 1-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)
fd0c: hard error reading fsbn 19 of 10-35 (ST0 44<abnrml,top_head> ST1 1<no_am> ST2 1<no_dam> cyl 0 hd 1 sec 2)

mcopy *seems* to work, it's reading them that seems to be the problem
not only on this box but other boxes and OSes too.

Any ideas?

-- 

 Frank 

*-*-*-*-*-*-*-*-*-*-*
   Boroughbridge.
 Tel: 01423 323019
     ---------
PGP keyID: 0xC0B341A3
*-*-*-*-*-*-*-*-*-*-*

http://www.esperance-linux.co.uk/

  90% OF MEN HAVE A SMALLER THAN AVERAGE PENIS - ARE YOU ONE OF THEM?
  			- spam




More information about the Ukfreebsd mailing list