Major HW problems

Henrik Morsing henrik at morsing.cc
Fri Dec 5 21:36:11 GMT 2003


My server has been randomly resetting itself, rebooting and locking up.
Now it even has problems booting and I got these messages:

When trying to mount /:

Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x80000014
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc02672dc
stack pointer           = 0x10:0xce936cf0
frame pointer           = 0x10:0xce936cf8
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 9 (sh)
interrupt mask          = net tty bio cam
trap number             = 12
panic: page fault


After manually fsck'ing and exiting shell:

Skipping disk checks ...


Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x80000014
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc02672dc
stack pointer           = 0x10:0xce824c38
frame pointer           = 0x10:0xce824c40
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 51 (sh)
interrupt mask          = net tty bio cam
trap number             = 12
panic: page fault

syncing disks... 5 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
giving up on 1 buffers


And on attempting to boot:

CPU: AMD Athlon(tm) Processor (1244.71-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x662  Stepping = 2

Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PA
T,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory  = 307560448 (300352K bytes)
panic: vm_page_insert: already inserted
Uptime: 0s

I am almost sure it's a motherboard problem and not a memory or CPU
problem because of the way it died the first time. I still have my shell
alive bu any command I tried froze.

Any thoughts?

Cheers
Henrik Morsing




More information about the Ukfreebsd mailing list