freebsd using ADSL router, help!

James james at
Tue Oct 29 07:42:51 GMT 2002

Hi there, recently installed FreeBSD on one of my boxes, worked fine using
DHCP from the router, could ping, download, upload etc. Decided I wanted
somthing abit more powerfull then the standard port forwards and default
'firewall' that the router has to offer so decided to put the router in
half-bridge mode. Ive tried this before on windows 2000 using DHCP and it
seemed fine so i thought well why not any different in FreeBSD. As soon as i
put the router in half-bridge mode and use DHCP on FreeBSD the kernel
reports errors after getting an IP Address about:

/kernel: arplookup <ipaddy> failed: host is not on local network

/kernel: arpresolve <ipaddy> carnt allocate llinfo for <ipaddy>rt

with ipaddy being the current IP i have assigned.

If anyone else has got this working with FreeBSD then please let me know as
i am pulling my hair out and trying to narrow it down to arp spoofs from the
router are confusing FreeBSD?

Again this works fine using DHCP if the router in doing NAT
The make of my modem is AMX-CA64E
Oh and I'm running FreeBSD 4.7



More information about the Ukfreebsd mailing list