Input/output error

Paul Civati paul at xciv.org
Sun Nov 24 20:10:44 GMT 2002


"Rob King" <robking at hotmail.com> wrote:

> It looks to me as if there are some dud sectors? I ran an fsck:

fsck is effectively checking the consistency of your data (filesystem)
on the disk, this is different to checking the actual disk media/sectors.

> So i ran a dmesg - and to my surprise... (I've pulled out the relevant 
> lines):
> 
> ad4s1e: hard error reading fsbn 159012031 of 79505984-79506111 (ad4s1
> bn 159012031; cn 9898 tn 10 sn 31) trying PIO mode

Right.. that looks like bad media/sectors.

> Anyone any ideas? I'm not having much luck with IBM drives at the moment
> - at least one goes a year - this'll be my second!

Well, this is tricky I think, because you're using IDE/ATA.

Basically you need to map out those bad sectors to stop the o/s trying
to use them, with SCSI disks you would eg. go into the Adaptec SCSI bios
and run a verify, and it would scan the disk and mark any bad sectors
as unusable.

As far as I can make out, IDE/ATA doesn't really have this, you basically
have to low-level format the drive and the format utility will take out
the bad sectors at that point.  Often the manufacturers have their own
utility for low-level formatting their IDE/ATA drives.

When this happened to me I had a very very old disk and I couldn't find
a specific utility so I used another manufacturers instead and it made
an even bigger mess of the disk!  I think the disk was terminally broken
though.

I'm not sure how modern IDE/ATA drives handle bad media, but the above
is what I gleaned when I went through the problem.

Anyone know otherwise?  Time to ask google I think..

-Paul-





More information about the Ukfreebsd mailing list