Bridging Ethernet to Wireless (fxp0 <-> wi0) Orinico PCMCIA

George Minich gminich at toshiba.ca
Sun Mar 3 22:20:25 GMT 2002


This is a multi-part message in MIME format.

------=_NextPart_000_0007_01C1C2D7.B55B47E0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

  Hi all,

  I have been attempting to get a transparent bridge running with my =
FreeBSD 4.4 setup.  I have configured the kernel with all bridging and =
firewalling options.  I have run all of the necessary "sysctl" commands. =
 The problem is that there are almost NO packets being send from the =
wireless interface.  When I look at the TCPDUMP on the FreeBSD box, I =
see may ARP requests such as the who-has and so on.  It does not look =
like these packets are making it through.  I have set the firewall to =
pass all packets as well. Are there some secret settings that are not =
found in this document?:

   http://www.kozubik.com/published/freebsd_bridging_ipfw.txt

  Also, I have the both cards configured correctly (so I believe) as =
they are in promiscous mode and do respond to ping requests with IP is =
enabled on them - I currently have IP only in the inside, hard-wired =
ethernet card.

  Any ideas?

  Thank You All

  George


------=_NextPart_000_0007_01C1C2D7.B55B47E0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 5.50.4207.2601" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>&nbsp; Hi all,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp; I have been attempting to get a =
transparent=20
bridge running with my FreeBSD 4.4 setup.&nbsp; I have configured the =
kernel=20
with all bridging and firewalling options.&nbsp; I have run all of the =
necessary=20
"sysctl" commands.&nbsp; The problem is that there are almost NO packets =
being=20
send from the wireless interface.&nbsp; When I look at the TCPDUMP on =
the=20
FreeBSD box, I see may ARP requests such as the who-has and so on.&nbsp; =
It does=20
not look like these packets are making it through.&nbsp; I have set the =
firewall=20
to pass all packets as well. Are there some secret settings that are not =
found=20
in this document?:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp; <A=20
href=3D"http://www.kozubik.com/published/freebsd_bridging_ipfw.txt">http:=
//www.kozubik.com/published/freebsd_bridging_ipfw.txt</A></FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp; Also, I have the both cards =
configured=20
correctly (so I believe) as they are in promiscous mode and do respond =
to ping=20
requests with IP is enabled on them - I currently have IP only in the =
inside,=20
hard-wired ethernet card.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp; Any ideas?</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp; Thank You All</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp; George</FONT></DIV>
<DIV>&nbsp;</DIV></BODY></HTML>

------=_NextPart_000_0007_01C1C2D7.B55B47E0--





More information about the Ukfreebsd mailing list