More fun & games with ppp setup

CB ecliptica.ww at
Tue Jan 1 14:38:13 GMT 2002

Many thanks to Paul and to Robin for your most helpful advice.

Yes Paul, somehow I had got the modem connected to an incorrect (and
possibly non-functioning) back panel socket - removing the 9/25 way D-type
adaptor, which I use with the modem on this PC (MS Win), and connecting to a
9-way rather than the 25-way socket among the FreeBSD box serial outputs
certainly resolved the lack of any echo when in "term" from a ppp session.

I can now establish a connection manually using "term" to either of two
ISPs, at least to the point where I can get ping responses from the outside
world using IP numbers rather than DNS addresses:
e.g. "ping" works fine, but "ping" doesn't.

I've tried getting ppp to establish the connection automatically to one of
the ISPs (Virgin) using a "ppp.conf" file in /etc/ppp but all I get is "chat
script failed".

The meat of the "ppp.conf" file is as follows: (note the "set dial" string
has no end-lines in it)

    set device /dev/cuaa0
    set speed 115200
    set phone 08454550280
    set authname [usual ISP login uid]
    set authkey [usual ISP login pw]
    set timeout 300
    set openmode active
# end of ppp.conf

There are a few other lines (at present commented out) which I have tried
appending to the interactive section in an attempt to get the ISP to assign
IP addresses:
    set ifaddr
    delete ALL
    add 0 0 HISADDR

When I connect to Virgin manually using "term" the responses are as follows:

CONNECT 115200
Virgin CDF-CVX1-A   login:  [uid entered]
password:  [pw entered]
Exiting shell, and starting PPP session

I've read through the PPP and CHAT manpages and have also printed out a
couple of relevant sections from the "ppp-primer" docs you gave me the link
for Robin, but I can't see what the problem is with the chat script string
I'm using in the "set dial" command in the ppp.conf file.

Any advice or pointers would be most welcome.

All I'm trying to do is to get the box to a point where it can connect to
the 'net to do a cvsup so that hopefully I can finally get it to talk to its
CD ROM drive properly. The PC in question has been sitting with FreeBSD 4.0
only on it for about a year now gathering dust, and it's only now with a few
days vacation I've had a chance to make a sustained effort to try and get it
working properly.

I'm becoming a little more familiar with FreeBSD, but having gone through
2.2.3 (full 4 CD set and book purchased), 3.something (installed using an
online download), and 4.0 (Cheap*Bytes CD purchased) without ever getting to
the point where I have a system I can actually do useful things with .....

Many thanks for any helpful suggestions

More information about the Ukfreebsd mailing list