How to make my mounted root read/write without a /dev entry?

Clark C . Evans cce at clarkevans.com
Sun Feb 24 09:39:43 GMT 2002


Hello.  I'm a FreeBSD newbie, and I seem to have caught
myself in a catch-22 here...

Background
 
  I installed my system (4.4-RELEASE) and spend *hours* getting it 
  setup on a KG7-RAID motherboard with 2x40 GB HDD, 1GB RAM, and
  the HPT370 IDE-RAID.  I was very happy, almost ready to put it
  into production.  On boot it showed each of the sub drives,
  ad4/ad6 and then ar0, which is the raid "mirror" drive.  Neat.
  However, I tried to do some failure simulation by unplugging
  ad4 or ad6.  In some cases pulling ad4 is no problem, the 
  system continues; however pulling ad6 causes FreeBSD to lock.
  If 4.5 fixes problems with the HPT370 (as RAID), I'd
  love to know.   

  Anyway, I decided to drop the On-Board RAID and use Vinum
  instead and follow the instructions on the recent Vinum
  article... so far so good.  This requires me moving the
  HDD over to ad0 instead of ad4.  So, me being smart, I
  edited /etc/fstab, changing ar0 -> ad0.  Then I shut-down
  physically moved the drive, and rebooted.

Problem

  So now I have a system which should boot, but the problem
  is it lacks the entries in /dev ... I can boot using -as
  and mount the appropriate root, /dev/ad0s1a
  Now, from what I gather from the list, I need to:
  "cd /dev && sh MAKEDEV ad0s1a"
  Unfortunately, this requires me to have a read-write
  root partition.

Question
 
  How can I make my root partition read/write so that
  I can MAKEDEV?  The usual way, "mount -a" won't work
  for obvious reasons... my root partition does not have
  a device entry.  I also tried "mount -u -w / " to no avail.

Thanks!

Clark

P.S. Any insights as to how to get HPT370 to work or 
experiences with Vinum would be especially helpful as well.

  




While this works well for a niave person, I did some
failure testing and I found that simple hard drive
failures like a cable coming loose cause FreeBSD to lock.
Thus, I think FreeBSD+HPT3




More information about the Ukfreebsd mailing list