first major hurdle after install of 4.4

Will Macdonald wfm at macscan.co.uk
Thu Nov 15 16:25:36 GMT 2001


Hi all,

I have just installed FreeBSD 4.4 on my celeron laptop, and it all seems 
to work pretty well. I went for the normal User package and then added X 
4.1 after as suggested by the handbook.

I have managed to get X working luverly, as well as the wheel mouse.

I AM having problems with a USB keyboard though. I know it works in 
Windows and in Mandrake.

Here is an excerpt from dmesg:

uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xfce0-0xfcff irq 
5 at device 7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ukbd0: IBM IBM Standard USB Keyboard, rev 1.00/0.80, addr 2, iclass 3/1
kbd1 at ukbd0
ums0: IBM IBM Standard USB Keyboard, rev 1.00/0.80, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.

The keyboard also has a PS/2 port which I had the mouse on, but since 
moved it to the latop connector where it works fine.

I did a bit of searching, and some of the sites say that USB is 'flakey' 
and you really need to be using -CURRENT to get it working well.  Is 
this true or should a keyboard work fine in 4.4.

I tried following the advice about trying kldload usb, that did not help.

the following bits will be a bit less accurate, I didn't have time to 
write them all down.

I tried going into /dev and running 'sh MAKEDEV kbd(??). I also found 
instructions about running 'kbdcontrol -i /dev/kbd1' (?). The web site I 
was reading said kbd0 should refer to the normal laptop keyboard, and 
kbd1 should refer to the USB keyboard.  However when I ran the 
kbdcontrol program on kbd1, it reported that it used kbd0, the normal 
keyboard.

I then tried to run 'kbdcontrol -T or -t /dev/kbd1' and it came back 
with an error about not enough ioctl (?) or unable to load them.

The handbook seems to have nothing about nothing about USB devices from 
the contents page.

Would I be best to upgrade to CURRENT ?  I found a link in the handbook 
saying I should use 'cvsup standard.supfile' which I downloaded and ran 
after getting cvsup.  I tried using the url anoncvs.freebsd.org for the 
server but it didn't seem to accept connection. Can someone please point 
me to a London/UK based anoncvs server.

Thanks in advance for any help,

Will





More information about the Ukfreebsd mailing list