The Ports Tree -up-dating

Peter James p_f_james at lineone.net
Sat Nov 10 16:29:35 GMT 2001


I am still finding it impossible to up-date the ports tree, and I wonder if 
anyone on this group could just fault-find for me as follows.
1.The file cvsup-bin is located in /usr/ports/distfiles/cvsup-bin  Is this 
the correct directory for the file?
2. The file ports-supfile is in the same directory.  Is this correct?
3.  Once I have connected to my ISP using ppp papchap I run the following 
command from /usr/ports/distfiles/
               "cvsup -g -L 2 ports-supfile"
only to get the error message "Warning cvsup: Failed 1"

My ports-supfile reads:

*default host=cvsup.uk.FreeBSD.org
*default base=/usr
*default prefix=/usr
*default release=cvs tag=RELENG_4_4
*default delete use-rel-suffix
*default compress
src-all
ports-all tag=.

I am running FreeBSD 4.3 installed from CD's dated April 2001 copy right 
"WindRiver Systems" 2001.  I am at my wits end and running out of 
patience.  I've got a copy of the FreeBSD Handbook but I can't find out 
where I my setup is incorrect.  It does seem a little vague on where the 
binaries and supfiles should be located, and I guess that's where I'm going 
wrong.
It might be indicative that whilst I can connect via dialup, I can't 
install a port either.  I can browse and send E-mail OK though.
Am I doing something so wrong that I'll never get the ports update done?  I 
would appreciate any help.  I would like to junk Windows, but until I can 
get FreeBSD working at least reasonably satisfactorily that is a pipe dream.
Many thanks

Peter James
please reply to: pfjames at pingu.co.uk





More information about the Ukfreebsd mailing list