boot manager problem

Ben Paley rambhai at harpincher.freeserve.co.uk
Wed Aug 29 20:46:13 BST 2001


This sounds so familiar to me. I'm no expert and, though I've had to do what
you want to do several times (because of having to re-install Windows, of
course) the exact process seems to have been slightly different each time. But
here goes...
	First of all, you want to boot from your own kernel, so you've got
access to all the things you need. Do this by booting from the cd, then
pressing [space] just about instantly after the bootloader begins. Don't wait
'till it says"Press enter to continue... "and whatever else. Then you have to
tell it by hand where your kernel is. My BSD installation is on the first
partition of my first drive, and so the command is

0:ad(0,a)/kernel

The first 0 is the bios_drive, should be 0 for you too if it's your first or
only drive (primary master - might be 1, 2 or 3 if it's somewhere else)
	ad is the sort of controller: again, it should be the same if you've
got 4.0, but it may be worth trying wd. Or maybe not.
	0 is the first drive again. I have only the vaguest notion why you need
to put it twice, but you do.
	a is the slice (or "partition") I think it might use the first BSD
partition by default if you don't put "a", so you could try leaving it out,
or try "b" if it's the second partition...
	/kernel is pretty self explanatory. If your kernel is anywhere unusual
you'll have to put something different there.
	I know that's a lot of permutations, but one of them should work.
	Then you'll be booting from your oun kernel. If you had a fsck
failure then it's possible you'll get a problem when BSD tries to mount that
partition. If so you might have to edit /etc/fstab and comment out the
partition that's giving you a problem... but if you've re-instaleed since then
you should be ok.
	Once you're into your own kernel you can run a program called
boot0cfg
	Read the man page, but heres what worked for me:
boot0cfg -B /dev/ad0
	That's -B to tell it to actually bloody install the thing (why is that
a switch?) and /dev/ad0 because it's the first disk, which is ad0. That should
be the same with you. Though I seem to remember that the first time I did it I
just used
boot0cfg
so maybe that'll work for you. Then the LAST time I did all this (and never
before) I seemed to need a file called /boot.config (that's the whole pathname,
/boot.config) containing a single line, which in my case is
0:ad(0,a)/kernel
and in yours will be whatever finally worked for you (so keep a note of it!)
	Argh. I hope this works for you. Do let me know how you get on.
	Cheers,
	Ben

 > Date: Tue, 28 Aug 2001 10:57:31 +0100 > From: Simon Kershaw
<simon at kershaw.org.uk> > To: freebsd-users at uk.freebsd.org > Subject: boot
manager problem > 
> I decided to take advantage of the Bank Holiday weekend (and my wife and
> children disappearing to my in-laws for a week!) to upgrade from FreeBSD
> 4.0 to 4.3 (typical that 4.4 is scheduled for release this week, but
> never mind).
> 
> The short question is that I can no longer boot anything (except off
> CD). I have a suspicion I may have trashed the Boot Manager. Any
> suggestions as to how I can check this and/or re-install just the Boot
> Manager?

====================================================
Ben Paley & Tab Hunter http://www.blazingstrings.com
====================================================




More information about the Ukfreebsd mailing list