boot manager problem

Simon Kershaw simon at kershaw.org.uk
Tue Aug 28 10:57:31 BST 2001


I decided to take advantage of the Bank Holiday weekend (and my wife and
children disappearing to my in-laws for a week!) to upgrade from FreeBSD
4.0 to 4.3 (typical that 4.4 is scheduled for release this week, but
never mind).

The short question is that I can no longer boot anything (except off
CD). I have a suspicion I may have trashed the Boot Manager. Any
suggestions as to how I can check this and/or re-install just the Boot
Manager?

The longer version:

This machine had a single 20 gig hard drive with three partitions. The
first contained Win98 (which was on the machine when I bought it, and I
left it there as a backstop when installing FreeBSD originally). The
second partition contained / and the third partition contained swap,
/usr, /usr/var and a general user slice. Boot Manager offered me three
choices, F1 for Win98, F2 for FreeBSD (which worked) F3 for FreeBSD
(which of course didn't work). So...

I removed a 40 gig hard disc from a Windows box (which for various
reasons had 2 x 40 gig discs in it) and bunged it in my FreeBSD box.
Rebooted and successfully mounted the new disc as an msdos partition. My
plan was to do a full install of 4.3 onto this drive, and then copy
across some of my settings from the other drive. 4.3 was on CD which I
had downloaded as an iso image from one of the FreeBSD sites. Did a full
install onto this drive on Sunday afternoon, and it ground to a halt
installing the ports collection .. left it running overnight, and still
hadn't finished Monday morning. So I interrupted it, rebooted 4.0 from
the other drive, checked mail etc. Then tried again. This time it
installed, then I made the mistake of agreeing to auto-config X. This
hung it, so I interrupted and tried again, this time refusing to config
X. This refused to boot, or rather didn't appear in the Boot Manager
list (in retrospect, perhaps because it was on a different drive?).

So, I rebooted off the first drive, reformatted the second drive and
made tar files of everything on the two BSD partitions on the first
drive (still with me?). The second partition also had on it several
earlier complete backups. This time I decided to do an upgrade install.
This went through fine IIRC until it came to reboot. [footnote: I seem
to recall that there was an error actually -- fsck had failed on one of
the partitions.] At that point the BIOS could find nothing to boot from.
I tried again, with the same result. I tried the Fixit option of
sysinstall, with the tools from the second CD (the 4.0 version, but
seemed okay) -- I was able to fsck and mount the other partitions,
including the Win98 one and /, and they looked vaguely okay. Couldn't
see the second drive, but never mind for now.

Getting a bit frustrated, as Monday gradually disappeared, I
accidentally reformatted the /, /usr, and /var slices of the first drive
(forgot to toggle the newfs flag in /stand/sysinstall, grr), which means
that I now had to do a full install on these partitions. (My users
partition, with my own home directory and the older backups seemed to be
still okay when examined via Fixit and the tools CD). Did a full
install, went through okay, but still wouldn't boot.

So, to cut to the chase. My diagnosis is that I have screwed up the boot
manager track on the first drive, even though in sysinstall I said each
time to install one. Does that seem a reasonable diagnosis? If so,
what's the simplest way of ensuring that I have a valid boot manager
installed?

Any other ideas?

Thanks very much for any suggestions -- as you might imagine I am pretty
frustrated by all this, especially as I now have a nice lump of plastic
and metal and silicon sitting under my desk at home :-(

-- 
Simon Kershaw
simon at kershaw.org.uk
Cambridge, England




More information about the Ukfreebsd mailing list