New FreeBSD's users Questions

Mark Blackman tmb at maddog.u-net.com
Sun Jul 16 16:22:24 BST 2000


> What is the direct equivalent of rpm -qa for FreeBSD - i.e. a list of 
> all currently installed packages.
/usr/sbin/pkg_info -a -I

> Just how out of date is the FAQ / Handbook? i.e. it suggests the 
> use of controller rather than device for my hardware, yet config 
> complains - its dated. Is the documentation brought up to sync 
> with 4.0, release?
the documentation is brought up to date by a team
of over-worked volunteers. either file a PR (using 'send-pr')
or better yet, submit some patches that correct the documentation.

> Has anyone any experience with setting up a dialup PPP 
> connection on 4 - with the userland / kernel ppp. The handbook 
> section claims that the tun drivers are in the generic kernel, but 
> ifconfig can find none (in GENERIC or my kernel) . I have all the 
> needed ppp details from the old linux setup. I have also used 
> MAKEDEV tun0 to create the device entry.
tun* should be there. 'ifconfig -a' will give you a complete list
of available drivers.

> Can someone help me compile a custon kernel and add my CD-
> ROM, soundcard and network card. Yes, I have read the handbook 
> section, and followed it, and do have a makefile derived from 
> GENERIC. The entry for my netcard isn't known - its in the generic 
> kernel, but in whch driver, I am unsure.
we can help!

> I have a DLink DE 528 PCI Adaptor 
> Its NE2000 compatible, so I guess ed0 was the driver.
> The entry does want some details I don't know - it is, however, on 
> IRQ 11, and linux found it automatically. Compiled into my custom 
> kernel, the card times out.
if its PCI, the kernel should do all the work assuming its compiled in.
can you show either '/sbin/dmesg' output or 'pciconf -l' output.

> I have a SB16, ISA card on factory settings. IRQ 5, DMA 1,5 etc 
> Its compiled in and works with my new kernel - with a lot of 
> warnings about compatibility mode. What driver should be used to 
> replace snd?
use 'device  pcm' instead and no specific drivers.

> Attached to the soundcard is an old Matsushita CR 562 drive. This 
> is not supported in GENERIC, and is causing me major problems. 
> I've copied the entry from LINT into my custom kernels file, and it is 
> compiled in - at least matcd.c can be seen in the list during 
> compile. The CDROM is on the default settings - those specified in 
> the LINT entry. Its supported under Linux in the sbpcd driver, and is 
> found at address 0x230 No trace of it is seen in booting, or when 
> looking at the kernel output with dmesg. I have created the dev 
> entries, and tried to both mount cd9660 (iso9660 to me ;-)) and 
> play audio cd's - no luck. The cd9660 FS is compiled in, and is 
> available as a lkm in the modules dir.
umm. I seem to recall that Matsushita CDROM may no longer be supported. 
I think I've seen e-mails to suggest thats the case. If so and you 
really need matsushita support you may have to go back to 3.x or so.

sure. send some dmesg and configs.

- Mark Blackman




More information about the Ukfreebsd mailing list