Installation Error

Paul Civati paul at xciv.org
Tue Apr 25 15:23:20 BST 2000


Steve Greenshaw <steve at softgreen.co.uk> wrote:

> Whilst trying to install 3.4 I keep on getting this error:
> 'Error mounting /mnt/dev/da0s1f on /mnt/usr : Invalid argument'
> Could anybody offer me any help?

I've found that sometimes the installer gets a bit confused if
you start an installation, it goes wrong or you decide to start
again and it forgets you already have devices mounted.

Also worth noting (but I downloaded the ISO so never saw the problem):

***
As shipped, the "Custom" installation option in 3.4 is broken
and menu items like Configure don't work

Fix: Both the "Novice" and "Express" install paths still work and
     can be used just as effectively (if not succinctly).  Alternately,
     you can invoke the custom installation from the "Index" menu
     (Installation, Custom) along with the Configuration option.  You
     can also just download a fixed mfsroot.flp floppy image (or boot.flp
     if you need 2.88MB boot media) from the following URL: 

ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/3.4-RELEASE/floppies/updates/

     The 3.4 ISO installation image is also updated to contain fixes
     for all these errata items.
***

> I'm trying to install on a twin CPU board with 64Mb RAM, 1 x 8Gb SCSI, a
> CD drive as a Secondary Master. No Primary master (although I get the
> same error with the CD as Primary master) and an NE2000 PCI NIC.
> 
> The only other version of FreeBSD I've used was 2.2.5 and never
> encountered anything like this before. Having said that, I've never
> tried a twin processor job before. Could that cause a problem?

I don't think this is a hardware problem, this is an installer issue,
the mount of the newly created filesystem is failing.

-Paul-




More information about the Ukfreebsd mailing list