PPP Configuration Problems!

Mark Ovens mark
Wed Sep 1 21:31:15 BST 1999

On Wed, Sep 01, 1999 at 08:59:42PM +0100, Andrew Boothman wrote:
> On 01-Sep-99 Brian Somers wrote:
> > $ ls -ln /usr/sbin/ppp
> > -r-sr-xr--  1 0  69  239568 Aug 25 21:08 /usr/sbin/ppp
> Ah Ha! I've found it. In one of my attempts to get this to work I'd removed the
> 's' from the permissions on ppp. A quick chmod u+s /usr/sbin/ppp has fixed it.
> Many thanks for all your help.
> I'm always interested in learning new things about Unix, so what exactly is
> this 's' in the permissions? Is that the setuid bit that Mark mentioned?

Yes, it is, although I tried removing it but got a slightly different error, "Permission denied", rather than "Operation not permitted" (or the other way round). I too am running 3.1 off the CDs and the ppp that came with it. Strange.

> What purpose does it serve?

It allows a user to assume the UID, and hence the priveleges, of
the owner (usually root) of the program, but *only* within the
process that the program is running in. Therefore normal users can
run such programs without knowing the root password.

For example, I'm running ppp as user "mark", which ps(1) reports:

mark     277  0.0  1.6  1404 1024  p1  Ss+   9:18PM   0:00.28 ppp isp

However pid 277 has root privelege, e.g. it can read & write to
/dev/tun0 and manipulate the routing tables which the user "mark"

> Thanks once more.

You're welcome.

> ----
> Andrew Boothman <andrew at cream.org>
> http://sour.cream.org
> Unmetered Telecoms. Join the Fight!
> http://www.unmetered.org.uk

STATE-OF-THE-ART: Any computer you can't afford.
OBSOLETE: Any computer you own.
      FreeBSD - The Power To Serve http://www.freebsd.org
      My Webpage http://ukug.uk.freebsd.org/~mark/
mailto:mark at ukug.uk.freebsd.org              http://www.radan.com

More information about the Ukfreebsd mailing list