PPP Configuration Problems!

Brian Somers brian
Tue Aug 31 23:11:28 BST 1999

> > WRT the Operation not permitted bit, is ppp installed properly ?  
> > This error would result if ppp tried to open the tun device as a 
> > normal user :-/  Is there anything ``manual'' being done when 
> > installing ppp ?
> > 
> Hmm, I'd be interested in the outcome of this. I sort of worked
> out that it was when trying to open tun0, but I couldn't reproduce
> it on my system no matter how much I changed. I got this if I
> removed the setuid bit on /usr/sbin/ppp:
> marder-1:/usr/marko{52}% ppp
> Working in interactive mode
> Warning: No available tunnel devices found (Permission denied).
> Warning: bundle_Create: No such file or directory
> marder-1:/usr/marko{53}% 
> not *quite* the same error ("Permission denied" rather than "Operation
> not permitted").

Yes, there's something funny going on in GENERIC.  There are no tun 
devices present any more.... I've asked phk about it as he was the 
last to muck about there.  There may be something different happening 
in -stable - I'm not sure yet.

Brian <brian at Awfulhak.org>                        <brian at FreeBSD.org>
      <http://www.Awfulhak.org>                   <brian at OpenBSD.org>
Don't _EVER_ lose your sense of humour !          <brian at FreeBSD.org.uk>

More information about the Ukfreebsd mailing list