Sony Tape Drive

Steve Greenshaw smg
Mon Aug 16 16:12:38 BST 1999


Thanks for that. Yes, the tape shows up as:

(ahc0:0:0): "SONY SDT-9000 0400" type 1 removable SCSI2
st0(ahc0:0:0): Sequential-Access density code 0x13, drive empty

So ... that's good news. Now then. I tried the following to backup two files (just
dummies) using TAR:

'tar cfb /dev/st0 fileone filetwo'

Seemed quite happy .. no 'what the f*** do you mean by that!' errors, so I deleted
the two files from their original location and then realised that I did not know the
name of the archive that they were in on '/dev/st0'. How do you name an archive when
you create is?

Hmm .. tried 'tar --extract fileone'

OK. So ... watching the tape drive, it is being accessed when I try to '--extract'
an archived file.

Then I get told that 'fileone' doesn't exist in the archive.

I mean ... what's going on?

Grrr ....


Josef Karthauser wrote:

> On Mon, Aug 16, 1999 at 02:44:18PM +0100, Steve Greenshaw wrote:
> > Hi all,
> >
> > I was wondering if anyone could point me in the right direction to mount
> > and use my Sony SDT-9000 series DDS tape drive?
> >
> > In /etc/devices there is an entry for 'st0' which is the unit number of
> > the tape drive, but anything beyond that is a mystery to me. I'm running
> > FreeBSD 2.2.5 and want to backup each of my 9Gb SCSI's ...
> >
> > Regards,
> >
> > Steve.
> 2.2.5?  You'll want to take a look at upgrading to 3.2 - it's much funkier :).
> After a reboot, type '/sbin/dmesg | more'.  Does the tape drive identify itself?
> If so then take a look at 'man dump' and 'man tar'.  These tools talk directly
> to a tape machine.
> Joe
> --
> Josef Karthauser        FreeBSD: How many times have you booted today?
> Technical Manager       Viagra for your server (
> Pavilion Internet plc.  [joe at, joe at, joe at]
> ------ FreeBSD UK User's Group  -  Mailing List ------

More information about the Ukfreebsd mailing list